Versionsangivelser, composer vs bower

Edit 140201: Spoiler alert! Efter lite grävande såhär på lördagskvällen hittar jag att detta är en bugg i bower: bower/bower#1017.

Jag var på väg att slänga upp detta på twitter men inser att det knappast får plats på 140 tecken.

Något jag har stört mig på ett tag är att composer och bower verkar ha olika uppfattning om hur man anger versioner i sina JSON filer.

Om jag anger t.ex. ~1.0 i composer så får jag den senaste versionen i 1.x trädet som är stabil:

$ composer require nelmio/security-bundle 
Please provide a version constraint for the nelmio/security-bundle requirement: ~1.0
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
(...) 
  - Installing nelmio/security-bundle (1.3.0)

Medan om jag gör samma sak i bower så får jag senaste i 1.0 trädet:

$ bower install 'ember#~1.0'
bower ember#~1.0                cached git://github.com/components/ember.git#1.0.1
bower ember#~1.0              validate 1.0.1 against git://github.com/components/ember.git#~1.0

(...)

ember#1.0.1 bower_components/ember

Provar jag med ~1 så får jag senaste beta versionen:

$ bower install 'ember#~1'
bower ember#~1                  cached git://github.com/components/ember.git#1.4.0-beta.3
bower ember#~1                validate 1.4.0-beta.3 against git://github.com/components

(...)

ember#1.4.0-beta.3 bower_components/ember

Är det någon av dem som har mer “rätt”? ..och hur fasen får jag bower att installera version 1.3.1 (senaste stabila) av Ember?